How to troubleshoot system error code – 1053 raised by TopTeam Application Server service

Overview

When the TopTeam Application Server service does not start, it is generally caused by the system error code – 1053 when Windows Service fails to start.

This article helps you identify which component is causing a problem in starting the TopTeam Application Server service and find the appropriate troubleshooting solution.

Who should read this?

  • System Administrators
  • TopTeam Administrators
  • IT Support

1. TopTeam Application Server has expired

Cause:

TopTeam Application Server is running in TRIAL mode and has expired.

Identify:

To identify the reason, uninstall TopTeam Application Server as a Windows Service and start it in Application Mode. The Expire dialog will be displayed if it has expired.

Solution:

Enter Trial Extension Key or Registration Key in the window displayed to fix this issue.

2. TopTeam Application Server is not able to connect to database

Causes:

a. Incorrect Username, Password or connect string is used for connecting.

b. Credentials under which the TopTeam Application Server service is running do not have enough privileges to connect to the database.

Identify:

To identify the reason, check Application Event Logs (Press the Windows key on keyboard and type Event Viewer) of TopTeam Application Server error related to the database connection.

Solution:

Provide the correct database login credentials and ensure that the Windows credentials under which the TopTeam Application Server service is running have privileges to login/connect to the database.

3. TopTeam Application Server cannot write to the TopTeam Application Server installation folder

Cause:

Credentials under which the TopTeam Application Server service is running do not have enough privileges to write to the TopTeam Application Server installation folder.

Identify:

To identify the reason, check Application Event Log (Press the Windows key on keyboard and type Event Viewer) in Event Logs of TopTeam Application Server error related to File Write privileges.

Solution:

Ensure that the Windows credentials under which the TopTeam Application Server service is running have privileges to login/connect to the database.

If the User Data Files folder is on the network, ensure that it is accessible.

4. TopTeam Application Server cannot write to the User Data Files Folder

Cause:

Credentials under which the TopTeam Application Server service is running do not have enough privileges to write to the User Data Files folder.

Identify:

To identify the reason, check the Application Event Log (Press the Windows key on keyboard and type Event Viewer) in Event Logs of TopTeam Application Server error related to File Write privileges.

Solution:

Ensure that Windows credentials under which the TopTeam Application Server service is running have privileges to login/connect to the database.

If the User Data Files folder is on the network, ensure that it is accessible.

5. TopTeam Application Server is not able to listen on the specified Port

Causes:

a. Specified Port is already in use.

b. Firewall is blocking TopTeam Application Server from using the specified Port.

Identify:

To identify reasons, check Application Event Log (Press the Windows key on keyboard and type Event Viewer) in Event Logs of TopTeam Application Server error related to a socket error.

Solution:

Stop or kill the application listening to TopTeam Application Server’s port. (Use Command line tool netstatb to get a list of open ports and their applications) or you can configure TopTeam Application Server to listen to a different Port.

Add an exception to Firewall for TopTeam Application Server’s listening Port.

If you do not find a solution to your problem, contact TechnoSolutions Support.

Revised: April 1st, 2020